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Code::Blocks and C compiler

* Ccompiler
* Inorder to run C code a C compiler is needed.
* Programmers write code in a “human readable form”. A compiler will generate a

corresponding special program that the computer can run.
IDE (Integrated Development Environment)
* isaprogram that is used to edit, compile, run and debug code, BUT it still needs a C compiler
in order to do that.
Code::Blocks is an IDE. It is NOT a C compiler

* You need both Code::Blocks itself and a C compiler.

* | have selected Code::Blocks because it has an option to download and install at the same
time both the IDE and a C compiler. It has other options that do NOT include the compiler so
pay attention to which installer you download.

Other IDEs are available (e.g. Apache NetBeans, Microsoft Visual Studio).
* Any IDE is fine, but you need to have a C compiler and set-up the IDE to find it.



Downloading Code::Blocks

From the Code::Blocks download page: http://www.codeblocks.org/downloads
Click “Download the binary release”
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Unix and Mac

* Mac users:

* For C compiler: install XCode from the AppStore
* Download and install Code::Blocks for Mac

e Unix/Linus users:

* Install the GCC (GNU Compiler Collection) compiler — E.g. search “install gcc
compiler on Unix” and follow instructions that seem clear to you.

 Download and install Code::Blocks for your system



Windows

Download codeblocks-20.03mingw-setup.exe - this is the package that has both Code::Blocks and a

C compiler (the MinGW C compiler). If you already have a C compiler or prefer to install the C compiler
separate, download the appropriate package (e.g. codeblocks-20.03-setup.exe).
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Install run the executable file you downloaded, agree to the terms.

When installing it, double-check that the MinGW compiler is checked/included

{1 Code:Blocks Installation _

Choose Components
Choose which features of CodeBlocks you want to install.

Chedk the companents you want to install and unchedk the companents you don't want to
install. Click Mext to continue.

-[¥] C2:B CBP2Make

----- C::B Share Config

..[#] €::B Launcher

L@ MinGW Compiler Suite

Select the type of instal: Full: All plugins, all tools, just everything =
Or, select the nptiqnal .. Default install
;f_lnsrg:ii:?nents Lt -- Contrib Plugins

Description
Space reguired: 531.5 MB

{77 CodenBlocks Installation _ W

Choose Install Location
Choose the folder in which to install CodeBlocks.

Setup will install CodeBlocks in the following folder. To install in a different folder, dick Browse
and select another folder. Click Install to start the installation.

Destination Folder

Browse. ..

Space reguired: 531.5 MB
Space available: 158.8 GB

< Back Install Cancel




We will use the GNU GCC Compiler.
(other C compilers should also be ok, but if available,
choose the GNU one for consistency.)

Compilers auto-detection O x

Mote: After auto-detection, at least one comnpiler's master path is still empty and therefore invalid,
Inspect the list below and change the compiler's master path later in the compiler cptions.
Select you favourite default compiler here:

” Set as default File associations W

Compi Status

GNU GCC Compiler Detected CodenBlocks is currently not the default application for C/C++ source files,
Do you want to set it as default?

You can always change associations from the envirocnment settings later.

() No, leave everything as it is

N i T in next time)
(®) Yes, associate CodeBlocks with C/C++ file types
oried type (including project files from other [DEs)

Current default compiler GNU GCC Compiler oK

C 1D




Check that you can “Build and run” a file.
Follow the next pages to create a file and try
to “Build and run” it. If it does not work, it

could be because Code::B

ocks cannot find

the C compiler. See page 13 (after the section

on creating and running a

C file) that shows

how to make Code::Blocks.



Create a C file, compile it and run it.



Project or no project?

* Larger pieces of code consist of multiple files and are developed using
a project that organizes all those files.

* You do NOT need to create a project for now. We will do that later on
so that we can Debug our code. (Method 2 below will be used to add
the file to a Project in order to debug it.)

* We will create just a Cfile.



Create an empty C file

Method 1:

File -> New -> Empty file  (This will create a file called
Untiltled)

File->Save file as...

Navigate to the location where you will store your code
from this class ( e.g. \courses\1310\code\lectures code
) and enter the desired file name: welcome.c

Method 2:

File -> New -> File ...

Select C/C++ source and click Go

Select C

Navigate to the location where you will store your code
from this class ( e.g. \courses\1310\code\lectures_code )
and enter the desired file name: welcome.c and click Save
Do NOT select Add file to active project click Finish

(Later we will need to add the file to a project in order to
be able to debug it, but for now, we will just create a file.)

C/C++ source

X

Please enter the file's location and name and
whether to add it to the active project.

Filename with full path:

es\1310\code\lectures_code\welcome.c |-

[ ] Add file to active project
In build target(s):

< Back Cancel
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Write code in the Cfile

Type the text below in the file (the text will be colored):

#include <stdio.h>

int main (void)

{
printf ("Welcome to CSE 1310!");
return 0;

yject  Build Debug Fortran  wxSmith  Tools  Tools+  Plugins  DoxyBlocks 5

{BRIQR)IEGr o0 ETE K
~ | 'mainivoid) : int
E%E*ﬂﬂﬂzﬁ‘iﬁﬂ v||<:z.:5:.ﬁ.__1}£€,_xg[:
X Start here welcome.c
P 1 #include «<stdio.h:
2
3 int main(wvoid) {
4q printf ("Welcome to CSE 1310117 »
=] retorn 0
g 1|
T
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Select: Build->"Build and run”

Note for future: make sure every time you need to compile and run your code
you select “Build and run”, not just “Run”. This way the new (most recent)
code is compiled, as opposed to running the previously compiled code. It is
similar to refreshing a webpage to enforce viewing the updated version.

5

t | Build Debug Fortran wxSmith Tools Tools+
B 3 Build Ctrl-F9 l
Compile current file Ctrl-Shift-Fo [
. = Run Ctrl-F10
'_E % Build and run F9 ;“ e
i Rebuild Ctrl-F11
Clean
1 Busiled sasnrbrmare

You should see this window pop up. Notice that the first line prints what you wanted.

B ChUsers\astefamod Documentshwelcome_2. exe

Welcome to CSE 1316!
Process returned & (8x8) execution time : 8.593 s

Press any key to continue.

You are all set.



“Build and run” does not
work

If you still can not build and run the C code,
make sure the C compiler is detected by
Code::Blocks. Go to:

Settings-> Compiler-> “Toolchain Executables’
and click the “Auto-detect” box

)

xyBlgeks Settings Help

: > bt Environment... E
Editor...
. Compiler... 1

Global variables...

Scripting...

Edit startup script

If it could not auto-detect the compiler:

Compiler settings

Global compiler
settings

X

e

Profiler settings

Batch builds

Global compiler settings .

Selected compiler

GMU GCC Cormpiler ~

Set as default Copy Rename Delete Reset defaults

Compiler settings  Linker settings  Search directories(’ Teolchain executables) Custom variables  Build 4 | *

Compiler's installation directory

| C:\Program Files\ CodeBlocks\MinGW

| .. || Auto-detect
MOTE: All prograrms must exist either in the "bin" sub-directory of this path, orin any of t =elitioes

Program Files  Additional Paths

C compiler: | gc.exe

C++ compiler: | g++.exE

|

|
Linker for dynamic libs: | ge++.exe |

|

Linker for static libs: | ar.exe

Debugger. GDB/CDE debugger : Default v

Resource compiler: |windres.exe |

Make program: | mingw32-make.exe |

- If you DO know where the compiler is, navigate to that location in the “Compiler’s installation directory” box

- If you do NOT know where the compiler is, there may not be a compiler on your machine. For Mac and Unix/Linux, you
need to install that separately. For Windows you can also install the compiler separately, but it is simpler to uninstall
Code::Blocks and then make sure you download the version that has the compiler (MinGW) together with Code::Blocks

(e.g. codeblocks-20.03-setup.exe). See slide 5.
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Other problems during installation?

* There should not be any problems during installation, but if you do
get some error messages, search the web. Include the error message
and your system (e.g. Windows 10).



Code::Blocks Settings

Editor Tweaks
To show line numbers and change other settings go to: Edit -> Select all
“Editor Tweaks” Select next occurrence
« And then “Show Line Numbers” Select skip to next occurrence
] Comment

* Also note the “Show EOL Chars”. EOL stands for End Of Line. Uncomment

Files from different Operating Systems will have different Toggle comment

EOL characters: Windows - CRLF, Mac — CR, Unix — LF. See Stream-comment

also the table from the Wikipedia page
https://en.wikipedia.org/wiki/Newline.

Box-comment

Goto matching brace

To change font size in Editor window:
Edit -> “Special commands”-> Zoom -> In/Out

Special commands

Editor Tweaks

Select all

Select next occurrence Ctrl-E

- TAB —to indent
- Shift + TAB — to decrease the indent

To indent a group of instructions: select the instructions and then click:

Ctrl-E
Ctrl-Shift-E
Ctrl-Shift-C
Ctrl-Shift-X

Ctrl-Shift-B

Movement

Zoom

Line

Case

el

Word wrap
Char wrap

Show Line Numbers

Use Tab Character

Tab Indents

Tab Size

Make Indents Consistent

Show whitespace characters

End-of-Line Mode
Show EQL Chars


https://en.wikipedia.org/wiki/Newline

Code::Blocks Settings

To restore the original perspective or % welcome.c - Code:Blocks 20.03

select other perspectives: File Edit View Search Project Build Debug Fortran wxSmith Tools Tools+ Plugins DoxyBlc
View -> Perspectives - Tl | Perspectives > |~ Code:Blocks default

You would need this if you closed some Watches Toolbars > Code::Blocks minimal
windows (e.g. Debugger, Build Messages) v Manager Shift-F2 GDB/CDB debugger:Default
and want them to be visible again. v Logs F2 Save current

You can also create your own perspective. Start Page Delete current

File Edit View Search Project Build Debug Fortran wxSr
T Perspectives >

If you cannot see the Projects Panel: Natches Toolbars >
View and check the Manager ¥ Manager Shift-F2

17



18



. Please select the folder where you want the new project
Create a project  saoecoscens

File Edit View 5Search Project Build Debug Fortran  weSmith

i i New i Empty file Project title:
File -> New -> Project ject fitls
= Open. Ctrl-0 Class... |Del::lugg|ngPrDJect |
Open With Hex Editor Project... . .
. Folder to create project in:
Open default workspace Build target... -
_ ) . | as at Arlingtencoursest 1310 codetlectures_code |

Select: “Console Application” [

Project filename:

Console

DebuggingProject.ch
and C“Ck Next application | ggingProject.chp |

Resulting filename:

| wres_code\DebuggingProject\DebuggingProject.chy |

Check the “Skip this page next time” - You will not see this welcome

next t|me _ [1iSkip this page next time

Select C for the language to use.

Please select the compiler to use and which configurations
you want enabled in your project.

Please make a selection CIICk GO
C++

Give the project a title (e.g. DebuggingProject) and%elect a folder to
place it in (e.g. lecture_code)

Compiler:
iGN GCC Compiler R

Create "Debug” configuration: | Debug |

The default configurations should work. Double check thatm/eDeng/ ‘Debug” options
and Release check-boxes are checked Output dir. | bin\Debug |

Objects cutput dir.: | chj\Debug |

Click Finish

. . . . [] Create "Release” configuration: |Release |
Done. You will see the project. (continue to next page) (in the ‘Release" options
Management panel under the Projects view) Outputdis | bin\Release |

Objects output dir.: | chbj\Release |



Using a project

Management

* You will see the project in the IDE. ¢ Projects Files  FSymb

(It is in the Management panel under the Projects tab.) @ Workspace
—E DebuggingProject
* By default a file called main.c was created in the project. To see it, =@ Sources

o rmain.c

click + next to Sources

* Double-click on main.c and it will open in the editor. It already
contains starter code to print hello world!

e Click Build and Run  # and see the program output

* You can edit the file main.c (write any valid C code in it) and run and
DEBUG that code.

Where are the project files? 1310 » code » lectures_code » DebuggingProject

o

* Usea file explorer program and navigate to the folder where you Name
created the project (e.g. 1310/code/lectures_code). You will find a M DebuggingProject.cbp
folder with the project name and inside there the project file (with
extension .cbp) and the main.c file

€ main.c

* Note: If you are using a different IDE, the location of the files and the
project file extension (.cbp) will be different.



Using a project

* A projectis a way to organize multiple files needed for a
larger application.

* You can close and reopen the project. This is convenient
when you have multiple projects.

Close a project

* When you close the project it simply does not SHOW in the
panel. All the code is still on your computer.

* To close a project right click on it and select Close Project

Management x

* Projects  Files FSymbols | *
QWQrkspace

I

=@ Sou Save project
Fo Close project

Open a project

 When you open a project, it makes it visible in Code::Blocks
and you can run and debug the code in that project from
Code::Blocks.

* To open go to: File-> Open and then navigate to where the
.cbp file is for the project you want to open



Project: add/remove files

You can add or remove files from a project.

Remove a file from a project

To remove a file: right-click on it and
select Remove file...

If you remove a file from a project it
does NOT delete the file, it simply
removes it from the IDE’s list of files
associated with that project.

Add a file to a project

e To add a existing file:
right-click on the project name
select Add files ... and
navigate to the file you want to add

* To create a new file and make it part of the project:

Make sure this project is active (it is listed and its name is in

bold font. If not, right-click on it and select Activate Project)
Go to File -> New -> Empty file

et et Click Yes to add this new file in the active project
SR - / Enter the file name
Do you want to add this new file in the active project (has to be saved first)?

Double-check that the Debug and Release boxes are
Yes Mo /C g

Multiple selection
Select the targets this file d belong to:
[] Debug

Release

hecked and click Ok

There are other ways to add files or rename files from a project.

There can be many .c files part of a project but ONLY ONE
int main (void) function.

If multiple .c files belong to a project, only one file can have a main function in
it.

For our class, you only need to have one .c file part of a project.



Using a project to Debug code

* Debug - The IDE provides a convenient framework to examine what is
happening with the program (what line is being executed at any time
and the value of the data in the program at that time). This is done in
DEBUG mode.

* In order to debug a program, it must be part of a project. (We can
run an individual file, but we can only debug a project)

* You have 2 options:

Option 1: Create a project for every program you need to run. If that is
for a homework, make sure you name the .c file with the required
name. The name of the project can be whatever you want.

Option 2: Create one project that will be used for debugging only.
When working on a program, add it to the Debugging project and
debug it as needed. Remove it from the project when you are done.

* You can have several .c file in a project, but only one of those files
can have a main() function in it (because that is where the program
execution will start and it cannot have multiple start points.)



Running individual files vs projects

 When you Build and Run... it will be done for the ACTIVE PROJECT.

* If you have multiple projects, make sure the one you want to work on
is active. (You can close the others, or explicitely make this one the
active one —right click on the project name to get that option)

* If you want to run a single file, then ALL your projects must be closed
(there should not be any project in the list of projects)



